Client Task Server failed to complete registration.
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Client Task Server failed to complete registration.

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Article ID: 169693

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Updated On:

Products

IT Management Suite

Issue/Introduction

The Task Server fails to register to itself when the Altiris Client Task Server Agent is not upgraded to the latest version as of the Symantec Management Platform (SMP) Server.

Error-1:
"Rule to open port: 80 (Symantec Task Server - HTTP connections) can not be added","Altiris.DotNetLib.Utilities.WindowsFirewall.AddRuleToOpenPort","AtrsHost.exe","2484","Warnings"
"Failed to perform re-register.
Error response returned from server: The handler 'RegisterTaskServer' is failed to process request. Registration of unsupported Task Server <Task Server GUID> version '8.0.3558.0' is rejected (expected version is '8.1.4511.0'). Please upgrade it or re-target it to another Notification Server that supports specified version of Task Server.

Error-2:
"Client Task Server failed to complete registration. Will be retried in 120 seconds.
Error response returned from server: The handler 'RegisterTaskServer' is failed to process request. Registration of unsupported Task Server <Task Server GUID> version '8.0.3558.0' is rejected (expected version is '8.1.4511.0'). Please upgrade it or re-target it to another Notification Server that supports specified version of Task Server.

Environment

Task Server 7.5.x, 7.6.x and 8.x.x

Cause

The Task Server is not upgraded to the latest version.

Resolution

Upgrade the Task Server Plug-in to the latest version to fix the problem.