Some Message Audit Log searches return Application Error

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Article ID: 169684

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Updated On:

Products

Messaging Gateway

Issue/Introduction

When searching Message Audit Logs from the Symantec Messaging Gateway (SMG) Control Center Status > Audit Logs page, some searches return the expected results but others return an "Application Error" page.

catalina.out
Jun 13, 2017 9:39:24 AM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet [flowServlet] in context with path [/brightmail] threw exception [java.lang.ArrayIndexOutOfBoundsException: 1] with root cause
java.lang.ArrayIndexOutOfBoundsException: 1
        at com.symantec.smg.controlcenter.monitoring.mal.AuditLogHandler.setEventData(AuditLogHandler.java:728)
        at com.symantec.smg.controlcenter.monitoring.mal.AuditLogHandler.access$1700(AuditLogHandler.java:87)
        at com.symantec.smg.controlcenter.monitoring.mal.AuditLogHandler$ActionEventHandler.end(AuditLogHandler.java:327)
 

Cause

Message Audit Log search results for some DKIM signed messages do not contain expected data regarding DKIM properties. The Control Center application server does not properly handle the missing data and generates an exception resulting in the Application Error page.

Environment

Messaging Gateway

Resolution

This issue has been resolved with the SMG 10.6.4 release.