Windows 10 Updates install resulting in BSOD

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Article ID: 169670

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Deployed Windows 10 Software Updates released for June 2017; found the Clients failing to boot with a Blue Screen of Death (BSOD).

Clients display as inaccessable boot device 

Cause

Confirmed during the cataloging of these Software Updates; the template for patch detection was chosen to be “non-security” versus security. This allowed the possibility of the delta patch to be evaluated outside the scope of the security roll-up. Ultimately, this enabled the possibility of the patch to be simultaneously deployed alongside the roll-up. 

Cumulative & Delta versions of Windows10.0-RS1-KB4022715-x64.msu and Windows10.0-RS1-KB4022715-x64_delta.msu installing on top of each other per targeting rule logic provided by the vendor of these Software Updates.

Resolution

The targeting applicability rule logic was corrected and this issue was resolved in PMImport v7.2.46 released on 6/16/2017.

Moreover, this has been extensively reviewed by Development to ensure this never happens again for neither Windows 10 nor Windows Server 2016 guaranteed, for detection logic will be added preventing these types of dual deployments.

This is detailed further on DOC9705; Clients will either be Applicable to the Delta or the Cumulative Software Updates in the monthly release. The targeted IsApplicable Rule Logic will then deploy/install either the Delta or Cumulative update; however, the Installed Rule Logic is going to return on scan to show both are installed via Compliance Reports per the Microsoft as the Client's state is the same regardless which update type is installed.

Allow for the PMImport to run on schedule, or open the Console > Home > Patch Management > Windows > Settings > MetaData Import Task; click on the New Schedule and run Now > Schedule, and this will run the process now and not interfere with the regular schedule: