After installing Protection Engine 7.9.0 the service will not start.

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Article ID: 169645

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Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

 

The installation of Symantec Protection Engine with the User Interface provided an indication that it completed successfully.  However, the Symantec Protection Engine service is in a stopped state and attempts to start the service fail.

 

Attempting to start the Symantec Protection Engine service returns the following error:

 

Cause

 

Symantec Protection has a service dependency on msvcr100.dll which is included in the Visual C++ 2010 (x64) runtime libraries which can be minimalized by statically defining the Java installation path in the system variables.

Environment

 

This issue impacts all supported versions of Windows.

Resolution

 

To resolve the issue please do one of the following:

  • Upgrade to SPE 7.9.1.  This version no longer requires the Microsoft Visual C++ run time library to be installed. 
  • Install Microsoft Visual C++ runtime libraries:
  1. Uninstall Symantec Protection Engine through "Programs and Features"
  2. Download and install Microsoft Visual C++ 2010 SP1 (x64) runtime libraries
  3. Install Symantec Protection Engine
  • Set Environment Variable path for Java installation:
  1. Uninstall Symantec Protection Engine through "Programs and Features"
  2. Open "System" properties.
  3. Choose "Environment Variables"
  4. In the "System variables" section select "Path" and then click Edit.
  5. At the start of the "Variable value:" add the full path to <JavaInstallPath\bin> followed by a semicolon.
  6. Example: C:\Program Files\Java\jre1.8.0_131\bin;
  7. Click OK until System Properties window is closed
  8. Install Symantec Protection Engine.