Updates from 10.6.0 to 10.6.2 fail

book

Article ID: 169631

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

Attempts to update Messaging Gateway (SMG) 10.6.0-7 to SMG 10.6.2-7 fails with a dependency error.
Updating SMG 10.6.0 to SMG 10.6.3 works as expected.

Error: Package: sms-appliance-release-10.6.2-7.noarch (symrepo_64_symc)
           Requires: msys-ecelerity-core = 4.2.24.56625-1
           Removing: msys-ecelerity-core-4.2.1.51032-1.x86_64 (installed)
               msys-ecelerity-core = 4.2.1.51032-1
           Updated By: msys-ecelerity-core-4.2.25.57347-1.x86_64 (symrepo_64_msys)
               msys-ecelerity-core = 4.2.25.57347-1
           Available: msys-ecelerity-core-4.2.24.56625-1.x86_64 (symrepo_64_msys)
               msys-ecelerity-core = 4.2.24.56625-1
Error: Package: sms-appliance-release-10.6.2-7.noarch (symrepo_64_symc)
           Requires: msys-ecelerity-modules = 4.2.24.56625-1
           Removing: msys-ecelerity-modules-4.2.1.51032-1.x86_64 (installed)
               msys-ecelerity-modules = 4.2.1.51032-1
           Updated By: msys-ecelerity-modules-4.2.25.57347-1.x86_64 (symrepo_64_msys)
               msys-ecelerity-modules = 4.2.25.57347-1
           Available: msys-ecelerity-modules-4.2.24.56625-1.x86_64 (symrepo_64_msys)
               msys-ecelerity-modules = 4.2.24.56625-1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
1
Script done, file is /data/logs/update.log
2017-06-07 09:29:58 -0700 sms-appliance-release-10.6.2-7 was not downloaded.

Cause

The update is unable to resolve a software dependency for a required software package due to a higher version of the package existing in the software update repository.

Resolution

Updates to SMG 10.6.3-2 complete as expected.

Workaround

Perform an 'localinstall' update as described in KB TECH199708