After upgrade Reporter indicate Crul related warring and error in Journal log.

book

Article ID: 169544

calendar_today

Updated On:

Products

Reporter

Issue/Introduction

Reporter program upgarade is completely finished in successfully.

However, Reporter application indicate Curl related warring and error in Journal event log.

BCRJ:2017-05-XX XX:XX:XX (59254444) ALW.WARN.START

   src/sg_curl.cpp,262,

      main_79b83720(2042115872),,

   CURLOPT_RESOLVE is not supported in library 'libcurl.so' version 'libcurl/7.19.7 NSS/3.14.0.0 zlib/1.2.3 libidn/1.20 libssh2/1.4.2'. Please provide version 7.21.3 or later

BCRJ:2017-05-XX XX:XX:XX (59254444) ALW.ERRO.UPGRA

   src/sg_update.cpp,215,

      main_79b83720(2042115872),,

   Failed to resolve CURL update host 'bto.bluecoat.com'

Cause

Red Hat Enterprise Linux announcing an issue in which the older version was vulnerable.
Due to that, now forces Reporter to look for the curl lib that is on a version not susceptible to this vulnerability. 

Environment

  • Reporter version      : Linux edition of Reporter 9.5.x.x
  • Base OS                  : Enterprise Linux 6.4

Resolution

Upgrade for libcurl/7.21.3 or later