Cannot install or upgrade Symantec Endpoint Protection Small Business Agent.

book

Article ID: 169515

calendar_today

Updated On:

Products

Endpoint Protection Small Business Edition (Cloud)

Issue/Introduction

If uninstall of Endpoint Protection Small Business Agent doesn`t work via Control Panel -> Programs and Features, installation has to be removed by Symantec in-house tools like CEDAR, Norton Removal Tool or CleanWipe according to following procedure:

http://www.symantec.com/docs/TECH213385

However when attempting to uninstall Endpoint Protection Small Business Agent using CEDAR following errors are being displayed:

"Installation cannot be started unless you solve following issue(s): Reboot your computer"

"Symantec Endpoint Protection has detected that there are pending system changes that require a reboot. Please reboot the system and rerun the installation."

Reboot of the issued machine does not resolve the issue.

CEDAR.log shows following error message:

2017-01-04 14:46:04.431; INF; t=10548; CRemovalDialog::OnInitDialog(63) : CEDAR has begun, args: "X:\PKL\Desktop\CEDARTool.exe" -p c:\temp\

2017-01-04 14:46:04.431; INF; t=10548; CRemovalDialog::OnInitDialog(65) : Starting...

2017-01-04 14:46:04.478; INF; t=10548; ssRebootHandler::GetRebootRequest(450) : Last reboot time: [20170104144044] 28800, request time [This is only needed for reboot check] 28800

2017-01-04 14:46:04.478; INF; t=10548; ssRebootHandler::GetRebootRequest(499) : Volatile Reboot needed

2017-01-04 14:46:04.478; INF; t=10548; CCMESSystem::IsSymantecRebootPending(222) : An Symantec.cloud reboot request has been detected.

Cause

A registry key named "HKEY_LOCAL_MACHINE\Software\Symantec\SHS\Reboot\RebootVolatile" with following values:

"VolatileInd" (DWORD): 0000001

"RequestService" (DWORD): 00001770

"RequestEvent" (DWORD): 000002a

"BackenNotify" (DWORD): 0000001

Wasn`t removed after the initial installation. 

Resolution

Reset the value of "VolatileInd" to "0" under "HKEY_LOCAL_MACHINE\Software\Symantec\SHS\Reboot\" and run CEDAR again.

Note: Great care should be taken when modifying registry. You should back up the registry before making any changes. See the link under References for more information. Also note, that the values "RequestService", "RequestEvent" and "BackenNotify" within the mentioned registry key can vary depending on.