Cannot Work Incident in Servicedesk, Error - 'The Message Exchange Factory failed to fetch an exchange by the given name '

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Article ID: 169466

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Updated On:

Products

ServiceDesk

Issue/Introduction

Use of any Tasks and Actions functions when opening Servicedesk resulted with an inability to work on any incident.  They also reviewed the error logs, observing the exception error listed below.

Exception: Can't create RuleAction type 'Symantec.ServiceDesk.Cm.Automation.CmRulesetArgumentsProvider'.
[global] Can't create RuleAction type 'Symantec.ServiceDesk.Cm.Automation.CmRulesetArgumentsProvider'.
[global] System.Exception: Can't create RuleAction type 'Symantec.ServiceDesk.Cm.Automation.CmRulesetArgumentsProvider'. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ArgumentException: The Message Exchange Factory failed to fetch an exchange by the given name ---> System.ArgumentNullException: Value cannot be null.
[global] Parameter name: name
 

Cause

The Object Storage Default Exchange Name value had been cleared

Environment

Servicedesk and Workflow 7.5x

Resolution

  1. Open the Local Machine Info Editor on the Servicedesk or Workflow Server.
  2. Find the Data Storage Section
  3. Make sure that the Object Storage Default Exchange Name is set to local.orm