Unified Agent unable to connect on unpatched Windows 7

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Article ID: 169409

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Updated On:

Products

Web Security Service - WSS

Issue/Introduction

Unified Agent (UA) version 4.7.6 or newer does not run on an unpatched Windows 7 workstation. A fully patched Windows 7 workstations don't have a problem

 

Unable to connect to intercept because: The system cannot find the file specified

Cause

Previous versions of UA used SHA-1 code signing certificates. SHA-1 certificates were deprecated on January 1, 2017, so new versions of UA are signed with SHA-2 certificates. UA version 4.7.6 and later uses SHA-2 signed certificates. With a fresh install of Windows 7, without any Microsoft patches, does not support SHA2. When you install UA on a system that doesn't support SHA-2, the driver does not load.

 

*Please note:  Windows 7 will no longer be supported for Unified Agent after end of life from Microsoft January 14, 2020.  Windows 7 is not supported with WSS Agent.

Environment

Windows 7

Unified Agent

Web Security Service

Resolution

Install the patch that is associated with Microsoft Security Advisory 3033929. This Microsoft patch installs SHA-2 code signing support for Windows 7.

Symantec recommends a fully patched version of Windows 7 to work with UA.

However, as of this writing (25 October 2017), here is the minimal install for UA v4.8.1.203405 to work:

These requirements may change without notice with newer versions of Unified Agent.