Cannot access Google sites using Google Chrome version 56

book

Article ID: 169358

calendar_today

Updated On:

Products

Asset Management Solution Data Center Security Monitoring Edition Advanced Secure Gateway Software - ASG ProxySG Software - SGOS

Issue/Introduction

When accessing some Google sites like www.google.com or other Google services like Gmail or Google Drive, the Chrome browser displays error message "This site can't be reached" and error code "ERR_CONNECTION_CLOSED".

Cause

Chrome version 56 adds support for TLS 1.3 and some Google servers are starting to request TLS 1.3 encryption if compatible with the browser; however, not all versions of SGOS are compatible with TLS 1.3. As a result, these SSL connections fail to complete successfully.

Resolution

The SGOS versions that include fixes for this issue are the following:

     -SGOS 6.5.10.1 and later
     -SGOS 6.6.5.4 and later
     -SGOS 6.7.1.2 and later

Workaround

To work around the issue, specify 1.2 as the maximum version of TLS that Chrome supports.

Edit settings in the browser:

  1. Open Google Chrome.
  2. Enter the following in the address bar: chrome://flags
  3. Search for Maximum TLS version enabled.
  4. Change this setting from Default (which is TLS 1.3) to TLS 1.2.
  5. Restart the browser.

Alternatively, edit the Chrome shortcut properties and append the following to the end of the Target field:

--ssl-version-max=tls1.2