Unable to Connect to HTTPS Management Console - Error: "NoClassDefFoundError"
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Unable to Connect to HTTPS Management Console - Error: "NoClassDefFoundError"

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Article ID: 169347

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Updated On:

Products

ProxySG Software - SGOS

Issue/Introduction

When accessing ProxySG or Advanced Secure Gateway (ASG) via the Management Console GUI an error is presented in the top left corner as seen in the screenshot below. Upon clicking for more details you receive Java error "java.lang.NoClassDefFoundError". 

Cause

Java trusts a separate certificate store than the browser.  When custom Root Certificates are trusted by the browser, they may not be automatically trusted or run by Java.

The Java Applet can also experience problems when loading if it doesn't support TLS1.0, TLS1.1 or TLS1.2 depending on the supported version/s of the ProxySG's certificate.

 

Resolution

For issues with an untrusted certificate:

  • Log in to the proxy over 8081 or SSH.
  • Go to Configuration > Services > Console, and edit the HTTPS console.
  • Change the certificate that is presented to one that is trusted by Java. Additionally, the certificate in question can also be imported into the Java security settings in control panel. This will need to be done for every machine that is used to access this proxy.

For issues with TLS version incompatibility:

  • On the client machine go to "Configure Java" > Advanced tab.
  • Make sure TLS1.1 and TLS1.2 are enabled

Additional Information

See related article. 

Unable to Connect to HTTPS Management Console - Error: "bluecoat.sgos.ui.SG_UIApp.class"