After upgrading to SGOS 6.5.9.10 or later, ProxyCllient is unable to connect to the Client Manager

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Article ID: 169331

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Updated On:

Products

ProxySG Software - SGOS

Issue/Introduction

After upgrading to SGOS 6.5.9.10 or later, ProxyClient is unable to connect to the Client Manager. The admin log displays "Error downloading configuration file: [system error 12175]" and configuration file download fails. Client  software download fails as well.

Cause

In SGOS 6.6.5.1 or later and SGOS 6.5.9.10 or later, SSLv3 is disabled for security reasons. In previous versions, ProxyClient uses SSLv3 to connect to Client Manager.

 

Resolution

Upgrade ProxyClient to the latest version, which use TLS to communicate with the Client Manager:
  • ProxyClient 3.4 - a fix disabling SSL v3 is available in 3.4.4.10.¬†
  • ProxyClient 3.3 - a fix disabling SSL v3 is available in 3.3.3.3.