(WSS) UA Installation Error: "The File 'bcua_service.exe' is not marked for installation."

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Article ID: 169318

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Updated On:

Products

Web Security Service - WSS

Issue/Introduction

When attempting to install the Unified Agent (UA), you receive the The File 'bcua_service.exe' is not marked for installation error.

 

Cause

This is likely caused by registration keys that exist because of previous failed attempt to install the agent.

Resolution

  1. With Admin rights, open the regedit application.
  2. Remove the following registry keys:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\bcua-service
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\bcua-wfp
HKEY_LOCAL_MACHINE\SOFTWARE\Blue Coat Systems
  1. Search register for bcua and delete the entry or key associated with it.
  2. Also delete the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{some number}
  1. Locate the Unified Agent folder; it should be under Display Name. Remove the entire folder of {some number}
  2. Reboot the machine.
  3. Attempt re-installation.