Content Analysis log displays error messages and the appliance has stopped working
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Article ID: 169265
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Updated On:
Products
Mobile App Risk DetectionContent Analysis Software - CA
Issue/Introduction
The Content Analysis web management console shows "Unknown" in the Name, S/N, IP, Version, and Release fields.
Cause
Content Analysis has stopped ICAP scanning and some of the configured values are now missing. Rebooting sometimes solves the problem, but not always. The following error messages are recorded in the CA log:
avservice[3598]: Unknown,(172.16.168.74) rebooted,Reason: Unknown avservice[3598]: ERROR : MTAAccept: Could not ready server avwatchdog[3135]: ERROR : ICAP_sender::SendFileViaICAP: Cannot scan file when ICAP and SICAP are disabled avwatchdog[3135]: ERROR : ICAP_sender::SendFileViaICAP: Cannot scan file when ICAP and SICAP are disabled avwatchdog[3135]: ERROR : avwatchdog: CAS service stopped responding. Restarting ... avservice[4448]: ERROR : mkdirs: could not create dir (No such file or directory) avservice[4448]: ERROR : ModuleManifest::Load: handling: invalid xml file /kaspersky/manifest.xml:cannot open file avservice[4448]: ERROR : IModule: Failed to open manifest for vendor 3
Resolution
This behavior is caused by bug #231311. A firmware upgrade to CA version 1.3.7.1 (or higher) is required. You may need to restore to default in order to resume the service, and then perform an upgrade to 1.3.7.1. In some cases, the CA can be directly upgraded.