Supported Java, operating system, and browser versions for SGOS

book

Article ID: 169081

calendar_today

Updated On:

Products

Advanced Secure Gateway Software - ASG ProxySG Software - SGOS

Issue/Introduction

The following combinations of operating system (OS), browser, and Oracle Java Runtime Environment (JRE) versions are supported for SGOS on Symantec ProxySG and Advanced Secure Gateway (ASG):

  • In SGOS 6.5.x, 6.6.x, 6.7.x, and 7.x, the ProxySG Management Console and the Visual Policy Manager (VPM). 
  • In Advanced Secure Gateway 6.6.x, 6.7.x, and 7.x, the Management Console accessed through the Proxy tab, including the VPM.

This document discusses both the legacy VPM and the Web VPM that was introduced in SGOS version 6.7.4.3.

Supported versions are the OS, browser, and JRE versions that Symantec tested and validated for SGOS and Advanced Secure Gateway 6.6.x. Using other browsers, OSes, and JREs in your deployment might yield unexpected results and is unsupported.

Note: For systems running Java 11, see Support for Java 11 on ProxySG and Advanced Secure Gateway appliances

Resolution

Accessing the Management Console and Legacy VPM

 You can access the Management Console (in Advanced Secure Gateway, click the Proxy tab) using Java Web Start, or directly in a browser.

Accessing the Management Console through Java Web Start

The Management Console Launcher (Java Web Start) provides an alternative for deployments that cannot use the legacy method of accessing the console directly in a browser. The Launcher allows you to manage and launch multiple SGOS and Advanced Secure Gateway Management Console instances from a single interface. See Download the Management Console Launcher JNLP file to launch multiple Management Consoles for details.

Accessing the Management Console directly in a web browser

To continue using the legacy Management Console, you must meet the deployment requirements described in the Administration Guide, including a supported version of Java 8. Internet Explorer 11 is recommended.

Important Notes:

  • Google Chrome is not supported for SGOS/Advanced Secure Gateway. NPAPI support was disabled in Chrome 42, and it is now permanently removed from current versions of Chrome.
  • Mozilla Firefox version 52 and newer is not supported for SGOS/Advanced Secure Gateway. NPAPI support was disabled in Firefox version 52, and will be permanently removed from version 53 and newer.
  • For details on browsers that removed or disabled NPAPI, see Error: "browser no longer supports the NPAPI plug-in" or "This Plugin is not supported" when accessing the Management Console.
  • Use of 64-bit Java might cause the Management Console to fail to load. If this is the case, use a 32-bit version of Java.
  • While we do require a minimum version of Java for management of the SG, please note that this is a minimum version and we do support customers that inevitably have environments with newer releases of Java (as Java is frequently updated). In this case, if a customer is running a later version of Java, they should be able to use that version of Java to manage the SG, we would not expect the customer to have to downgrade their Java runtime environment.

Requirements for accessing Management Console through Java Web Start or a web browser

Operating System Browser Version
(to launch Java Web Start)
Minimum Java Version
Microsoft Windows 7 Firefox 46
Firefox 47
Java 8 Update 121
Windows 7 Internet Explorer 11 Java 8 Update 121
Windows 10 Internet Explorer 11 Java 8 Update 121
Windows 10 Firefox 47 Java 8 Update 121
Ubuntu 12.04 Firefox 46 Java 8 Update 121
Ubuntu 14.04 Firefox 46
Firefox 47
Java 8 Update 121
Mac OS 10.11.4 Firefox 47 Java 8 Update 121
Mac OS 10.11.4 Safari 9.1 Java 8 Update 121

Accessing the Web VPM

SGOS/Advanced Secure Gateway 6.7.2.1 and later versions include the Web VPM. The Web VPM allows you to manage your organization's policies in a redesigned web-based interface. Refer to the following requirements for the Web VPM:

Supported browsers

  • Google Chrome 60.0.3112 and later
  • Mozilla Firefox 57 and later
  • Microsoft Edge 42.17134 and later
  • Safari 10.1.2 and later

Note: Microsoft Internet Explorer is not supported. If Internet Explorer is your default browser (or if you use a supported browser that launches the VPM in Internet Explorer), you can right-click and copy the Visual Policy Manager link at the top right of the Management Console. Then, paste the URL into a supported browser.

Display resolution

  • 1366 x 768