After Moving Between SGOS 6.6.x and 6.5.8.8, Policy Installation Produces an Error Message

book

Article ID: 168890

calendar_today

Updated On:

Products

ProxySG Software - SGOS

Issue/Introduction

At some point in time you were running SGOS 6.6, but you have since downgraded to 6.5.8.8, you will received the following error message when installing policy:

Error: Variable Linker Error: variable not defined: 'variable.bc_notify1=variable.bc_notify2'

Cause

The primary reason for this is that the current policy created  from newer versions of SGOS includes features not supported within previous versions.

Resolution

To resolve this issue, use SSH to connect to the proxy CLI and issue the following commands:: 
  1. Proxy>en 
  2. Proxy#config t 
  3. Proxy#(config)ui 
  4. Proxy#(config ui) reset 
Resetting UI to bound system version... 
ok


After running these commands, close and re-open your browser windows and then install policy again.

If you have a sysinfo file available (https://proxyIP:8082/sysinfo), you can also check that for a mismatch between the SGOS version and the UI Version - it'll be at the top of the sysinfo, for example:
 
Blue Coat Systems, Inc., ProxySG Appliance System Information 
Version 7.0 
Title ProxySG Appliance System
__________________________________________________________________________
Version Information
URL_Path /SYSINFO/Version
Blue Coat Systems, Inc., ProxySG Appliance Version Information
Version: SGOS 6.5.8.8
Release id: 178490
UI Version: 6.6.2.3 (169141)

As you can see, there is a mismatch between SGOS and UI versions. The "Release id" is the build number of the SGOS version, the build number of the UI is listed in brackets behind the UI version number. This also shows that SGOS 6.5.8.8 is newer than SGOS 6.6.2.3 because 6.5.8.8 has a higher build number.

Workaround

Disable coaching/splash page (the notify-user object).