Error: "VPM Editor cannot be launched from this file"

book

Article ID: 168881

calendar_today

Updated On:

Products

Management Center

Issue/Introduction

Unable to open VPM due to error "VPM Editor cannot be launched from this file"

When launching the VPM editor in Management Center, the following error message is seen:

VPM Error

Cause

The Java Network Launch Protocol (JNPL) file is old and needs to be update in order to open the VPM.

Environment

Using Management Center to manage ProxySG policies.

Resolution

Open the VPM Editor with the new JNPL file when the VPM launcher window opens in the browser.

Workaround

This might still fail in some versions of java but there are 2 known workarounds at this time.

  1. Upgrade to Java version 8 
  2. Instead of connecting to Management Center over HTTPS, use HTTP.  For example, http://MC_IP:8080

Attachments