Metadata Refresh Error "Unable to Execute Job" using Cloud Data Protection

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Article ID: 168866

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Updated On:

Products

CDP for Salesforce

Issue/Introduction

When running a Metadata Refresh, the job does not complete and throws the following error in the container.log

[sfdc-business-process-0] ERROR c.p.a.s.b.BusinessProcessServiceImpl - Unable to execute job.
com.perspecsys.adapter.cloud.exceptions.CloudClientResponseStatusException: Received error HTTP status response: HTTP/1.1 404 Not Found ; HTTP request line: GET https://na11.salesforce.com/_ui/search/ui/UnifiedSearchResults?str=nevergetdata&searchType=2 HTTP/1.1

Cause

The reason for this error is that Global Search is disabled in Salesforce and the CDP gateway requires that Global Search be enabled in order to create metadata for local search.

Resolution

To resolve this issue, Global Search, which is inherent and dependent on Chatter, must be enabled in Salesforce.

Steps to enable Chatter / Global Search:
In Salesforce go to:  Setup > Build > Customize > Chatter > Chatter Settings > Enable Chatter