Unable to login into Reporter after upgrading to version 9.5

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Article ID: 168764

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Updated On:

Products

Reporter

Issue/Introduction

After upgrading from Reporter 9.4 to 9.5 some customers are reporting they are no longer able to log into the Reporter GUI
While the issue is generally reported for Reporter running on Linux similar issues may appear in a Microsoft Windows environment
 

Cause

In Reporter 9.5 SSLv3 is disabled by default.
if the OS on which Reporter is installed is running version OpenSSL 0.9.8 or earlier you will need to enable SSLV3 as this version of OpenSSL does not support either TLS 1.1 and 1.2 which are the only  SSL protocols enabled by default in Reporter 9.5

Resolution

In order to enable SSLv3 use the following procedure

- stop the reporter service
# /etc/init.d/bcreporter stop

- edit the preferences file
# cd /opt/bc/reporter/settings
# vi preferences.cfg

- modify the SSL / TLS options for the listener 8082

...
protocols = {
http = {
ssl = {
ssl_v2 = "false"
ssl_v3 = "true"                           <= Enable SSLv3 here
tls_v1 = "true"
mode = "enable"
use_default_cert = "true"
cert_file = ""
key_file = ""
port = "8082"
password = "0a94add0d5cae307f0fae"
tls_v1_1 = "false"                   <= If you want to disable TLS1.1
tls_v1_2 = "false"                   <= If you want to disable TLS1.2

} # ssl
ip = "0.0.0.0"
port = "8081"
} # http
...

- start the reporter service again
# /etc/init.d/bcreporter start