Unable to upgrade software on PacketShaper S-Series unit

book

Article ID: 168667

calendar_today

Updated On:

Products

PacketShaper S-Series

Issue/Introduction

After downloading the PacketShaper 11.x software and following the procedure to load the file and reboot, the unit came back to the old version of software.  

Cause

You should confirm that the image has actually loaded before rebooting the unit.  Sometimes this takes a couple of minutes after issuing the setup images add command.  If the image hasn't loaded completely, and the user reboots the image, the upgrade will fail and the unit will load the previous version.  

Follow the instructions below to verify image has been successfully added before rebooting.  

Resolution

Follow these instructions to load the image and reboot the unit. 
  1. Log in to BTO (https://bto.bluecoat.com) using your BlueTouch Online credentials. 
  2. Go to the Downloads tab in BTO and navigate to the PacketShaper page for your model. 
  3. Download the new software image and put it on a workstation the PacketShaper can access. 
  4. Open the File Browser: in the Advanced UI, go to the Info tab and click file browser. 
  5. Upload the image to the 9.258/image folder on your PacketShaper. Make note of the new filename as you will need to specify it when adding the image in step 7 below. 
  6. Access the PacketShaper CLI with a remote login utility. 
  7. Add the image to your PacketShaper: setup images add file://<filenameFor example: setup images add file://542368.bcsi 
  8. Before going to step 9, make sure that the new image has been added and loaded. Run the command: setup images show 
Example: 

setup images show 
------------------------------------------------------------------------------- 
List of Installed Images 
------------------------------------------------------------------------------- 
Release ID 532537 
Release ID 532945 
Release ID 533930 (A) 
Release ID 534295 
Release ID 534667 
Release ID 535202 

Total 6 images (A) Active image 
------------------------------------------------------------------------------- 


The (A) marker indicates which image will be loaded when the PacketShaper is next rebooted. Make sure the (A) marker shows the new image. If it does not show the new image after about 5 minutes, go back to step 7 and load the image again via setup image add file and then check again to see the (A) marker. 

Note: If you have more then 6 images, you will need to remove an image before adding the new one.  You can use the command setup image remove to delete an image.   
  1. Once confirmed that the (A) marker is set on the new image that was loaded, reset the PacketShaper with the command: reset 
  2. Confirm that the image has been upgraded and clear the browser cache to see new functionality in the release.