The 'show tech-support -bundle' command might cause high CPU utilization or high disk space utilization

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Article ID: 168272

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Updated On:

Products

XOS

Issue/Introduction

Invoking the 'show tech-support -bundle' command might cause high CPU utilization and related high I/O on the system and increase disk usage.

Cause

When the 'show tech-support -bundle' command is invoked, there is a section of the script that copies relevant files from the APMs, including the /var/log/ directory. Particularly on the VSX implementations, the script is also copying all of the files related to VSX within the opt directory under the APM's /var/log/ directory. Copying the Check Point VSX log files within the APM's /var/log directory might increase disk usage on the system.

Resolution

This problem will be addressed in the following XOS versions: 9.6.10, 9.7.6, 10.0.3, 11.0.0

Workaround

To prevent copying content of the /var/log/opt/ directory from the VAPs, replace the "tech-supportfile located in the /crossbeam/bin/ directory with a version of the file attached to this article. Follow the steps bellow to replace the file:

1. Copy the new version of the tech-support file to the CPM.
2. From the CLI log-in to Linux shell:
CBS# unix su 
3. Backup the original file and replace it with a new version:
cp /usr/os/bin/tech-support /usr/os/bin/tech-support.orig 
cp tech-support /usr/os/bin/tech-support 


 

Attachments

tech-support get_app