Admin user is no longer able to log in to the XOS CLI due to changing its default shell

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Article ID: 168175

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Updated On:

Products

XOS

Issue/Introduction

Two shells are generally used when administering the Bluecoat X-Series hardware, admin and root. Admin is generally used to log into the CLI to configure XOS.  Root is generally used to log into Linux and administer it.  

Cause

If a change is made to the admin account's default shell, the user will not be able to get into the CLI and instead will always see the Bash shell.  The admin user is basically locked out of the CLI with no XOS commands available.  To verify this is the issue that you are having, you can run the following command as admin from the Linux shell:

[[email protected] ~]$ ps -p $$
  PID TTY          TIME CMD
18574 pts/0    00:00:00 bash


 

Resolution

To change the shell used by the admin user, run the following commands:

First, list the shells available:
[[email protected] ~]$ chsh -l
/bin/sh
/bin/bash
/sbin/nologin
/bin/tcsh
/bin/csh
/crossbeam/bin/cli


Logged in as the root user, change the shell that admin is using:

[[email protected] admin]# chsh -s /crossbeam/bin/cli admin
Changing shell for admin.
Shell changed.


If you have inadvertently changed the root user to use the /crossbeam/bin/cli shell you can run the following command from the CLI to change it back:

POD2# un "chsh -s /bin/bash root"
Changing shell for root.
Shell changed.