Incorrect response to SNMP queries on virtual management IP address

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Article ID: 168110

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Updated On:

Products

XOS

Issue/Introduction

Describes a workaround for a situation in which the primary CPM's physical IP address responds to SNMP queries to the virtual management IP address (vip-addr). The issue has been corrected in XOS V8.5.3.When a management vip-addr is configured, you may see the following problem in SNMP queries on the management vip-addr:

09:51:39.903061 0:3:d2:e0:21:1 0:3:d2:11:5a:ce 0800 75: 10.9.1.154.1429 > 192.168.34.105.161: GetRequest(18)
09:51:39.903508 0:3:d2:11:5a:ce 0:3:d2:e0:21:1 0800 75: 192.168.34.101.161 > 10.9.1.154.1429: GetResponse(18)


In this example, the request was sent to virtual management IP address 192.168.34.105, but the response came from 192.168.34.101.

Cause

The management vip-addr receives the SNMP query but the response comes from the physical address of the primary CPM management interface.

This can happen if you configure the management vip-addr before configuring the secondary CPM, for example, when moving to dual CPMs from a single CPM, or by sequencing the configuration commands in the wrong order.

Resolution

The fix for this issue has been implemented in XOS V8.5.3.

Workaround

To correct the issue, remove the management vip-addr and then add it again.

For example:

CBS# config no management vip-addr 192.168.34.105
CBS#
config management vip-addr 192.168.34.105

Note: This workaround survives a CPM failover.