Detailed troubleshooting steps for Broken RAID issue on CPM

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Article ID: 167953

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Updated On:

Products

XOS

Issue/Introduction

Detailed steps in reference to Article 4551:Workaround to prevent "RAID Status Broken, RAID 1" - (includes recovery procedure)Customer reports a Broken RAID issue on the CPM and would like to troubleshoot if the steps found within Article 4551 needs to be pursued.

Cause

The steps are meant to identify a possible disk issue or a possible RAID integrity issue.

Resolution

1. Schedule a maintenance window 
2. Log the session of the CPM interfaction.
3. Verify if the two drives are recognized by executing the "cat /proc/scsi/scsi" command.  If there are two disks shown within the /proc/scsi/scsi file, one can use the /crossbeam/bin/xos-raid-add utility to start RAID sync.
 
[[email protected] root]# /crossbeam/bin/xos-raid-add
 
4. In addition, please gather the following and upload to the case for review:
cat /proc/mdstat 
cat /proc/partitions 
smartctl -a /dev/sda 
smartctl -a /dev/sdb 
Collect the local logs from the CPM that has the broken RAID alarm (/crossbeam/logs/* & /var/log/*)
 
5. If the drive is not recognized in step3, please schedule and power cycle the CPM in question, and then run the same set of data collection steps (listed in step 4) after the reboot. 
6. 'show module status' cpX to check raid status and go to next step if you see "Broken RAID" 
7. Run '/crossbeam/bin/xos-raid-add ' and run "cat /proc/mdstat " to very RAID status 
8. Collect the local logs from the CPM that has the broken RAID alarm (/crossbeam/logs/* & /var/log/*) 
9. Upload the requested data from step5 for review. 
10. Monitor for re-occurrence of the disk issue. 
11. If the RAID rebuilt process fails, please contact support.

Workaround

n/a