Error: "subscription communication status: local has update errors"

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Article ID: 166952

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Updated On:

Products

Asset Management Solution Data Center Security Monitoring Edition Advanced Secure Gateway Software - ASG ASG-S200 ASG-S400 ASG-S500 SG-300 Symantec WebFilter (formerly Blue Coat WebFilter - BCWF) SG-600 SG-S500 SG-S400 Secure Web Gateway Virtual Appliance SG-S200 ProxySG Software - SGOS SWG VA-100

Issue/Introduction

Subscription Communication Status is in Warning/Critical state and displays failed download attempts even after database download issue is fixed in Proxy

In the Proxy appliance Management Console, the health status is in a Warning or Critical state and Health Monitoring displays the error "Subscription Communication Status: Local has Update Errors" although there are no current download errors.

This issue occurs after previous database download problems have been resolved, yet the Proxy is not clearing error.  The syntax error was fixed but it is not downloading 

Cause

Error log is not being cleared on proxy.   For an example:

Download log:
  Local database download at: 2018/03/30 13:28:38 +0200
  Downloading from http://hemstitched/bluecoat
  File has not changed since last download attempt; no download required

Previous download:
  Local database download at: 2018/03/29 11:46:09 +0000
  Downloading from http://hemstitched/bluecoat
  Compiling database
    Defining category: Assurance_White list
      Warning: (line 556): URL scheme ignored: 'http s://support'<------------------------------------------------ERROR
    There was 1 warning
  Database date:        Thou, 29 Mar 2018 11:46:14 UT
  Total URL patterns:   49656
  Total categories:     8

Resolution

There are two possible ways to resolve this issue:

  1. After the Local Database server is back up and running, make a small change in the DB file. Adding a line with a comment (E g: ;test ) will also help. This will make the proxy see the change in file and download it fully.
  2. If editing the Local DB file is not possible, reboot the appliance. After the reboot, the error count is reset to zero and health status returns to OK.