Unable to access a list view or portlet when power filter is corrupt
search cancel

Unable to access a list view or portlet when power filter is corrupt

book

Article ID: 16623

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

You have saved a custom filter and are now unable to access a list view or portlet, such as the task list view or Timesheet Review portlet. The page may spin for some time and eventually throw a system error. 

Environment

Any Clarity release

Cause

This is due to a corrupt power filter. It can happen if you pick an invalid power filter or the combination becomes invalid.

Resolution

When you modify and save a filter, a record gets created in the cmn_attribute_value_sets table. If the filter gets saved as the default, then the specified filter is pushed as default when accessing that specific portlet/page. In order for you to access this page/portlet again, the saved filter will need to be set to no longer be the default. The only way to do this is by updating the record in the database table. 

  1. The following query can be used to check what custom default filters a user has set:

    select * from cmn_attribute_value_sets
    where is_default =1
    and user_id = <internal id of the affected user>

  2. Check the result set. Examples:
    • For the task list, the results include one row where the code is projmgr.odfKeyTaskList and the ID is 5016000.
    • For portlets, the code will be the internal id of the portlet. The portlet internal ID can be gathered from the URL that is generated when going to the properties of that portlet under Administration - Portlets.
  3. To make the saved filter no longer be the default, run the following update in the database:

    update cmn_attribute_value_sets
    set is_default =0
    where id = <id of value set pertaining to affected view or portlet>
    and user_id = <internal id of the affected user>

  4. After doing so, Clarity will default to the OOTB filter and the portlet will load without error. 
  5. Once you are able to log in, go to the Manage Filters option and remove the broken filter from the list 

Additional Information

See also: Restore Defaults to resolve corruption or errors