This configuration example shows a two port EtherChannel configured between a pair of Cisco 6509’s.
A PacketShaper is placed on each of the two EtherChannel links. This allows traffic to be load balanced
across the two PacketShapers. Traffic is generated between the hosts using a traffic generator which generates
100,000 HTTP flows to random source and destination IP addresses. The load balancing scheme used on
the 6509’s is src-dst-ip. The topology looks like this:
The traffic split over the two links is virtually 50/50. Each PacketShaper records very close to half the total flows.
The EtherChannel is configured using the Link Aggregation Control Protocol (LACP) which allows for failure
detection by the peer if one end of the link were to go down. Failover was tested by disconnecting the cable
between a 6509 and a PacketShaper. Traffic is seamlessly re-routed to the remaining link and that PacketShaper
then sees all 100,000 flows. When the link is restored, traffic is split 50/50 within a few seconds.
If one checks the avg-bps and number of new flows (tcp-conn-inits) which each of the
PacketShapers records, it ends up being very close to a even split.
PS_A# measure dump link inbound by time 3 5min avg-bps tcp-conn-inits
"link:/Inbound"
"time","avg-bps","tcp-conn-inits"
"05-Oct-2009 17:29:00",15916901,817158
"05-Oct-2009 17:24:00",15376893,803414
"05-Oct-2009 17:19:00",15822834,838755
PS_B# measure dump link inbound by time 3 5min avg-bps tcp-conn-inits
"link:/Inbound"
"time","avg-bps","tcp-conn-inits"
"05-Oct-2009 17:29:00",15905210,815323
"05-Oct-2009 17:24:00",15733261,796094
"05-Oct-2009 17:19:00",16023335,843746
Cisco 6509 configuration:
The traffic generators are connected to port Gi6/5 on each 6509.
Gi6/6 and Gi6/7 make up the EtherChannel on each 6509. These two ports are added to a Port-Channel
which in tern is associated with a Vlan. This example assumes a flat L2 topology. Note that on one 6509
the channel-group is “passive” while on the other it is “active”
hostname CompNet_CAT6509-1
port-channel load-balance src-dst-ip
vlan 800
interface Port-channel1
switchport
switchport access vlan 800
switchport trunk encapsulation dot1q
no ip address
!
interface GigabitEthernet6/5
switchport
switchport access vlan 800
no ip address
!
interface GigabitEthernet6/6
switchport
switchport access vlan 800
no ip address
channel-group 1 mode passive
!
interface GigabitEthernet6/7
switchport
switchport access vlan 800
no ip address
channel-group 1 mode passive
*******************************************************
hostname CompNet_CAT6509-2
port-channel load-balance src-dst-ip
vlan 800
interface Port-channel1
switchport
switchport access vlan 800
switchport trunk encapsulation dot1q
no ip address
!
interface GigabitEthernet6/5
switchport
switchport access vlan 800
no ip address
!
interface GigabitEthernet6/6
switchport
switchport access vlan 800
no ip address
channel-group 1 mode active
!
interface GigabitEthernet6/7
switchport
switchport access vlan 800
no ip address
channel-group 1 mode active
!
*******************************************************
Show the EtherChannel status
CompNet_CAT6509-1#sh etherchannel 1 sum
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Gi6/6(P) Gi6/7(P)
Show the load balance scheme
CompNet_CAT6509-1#show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
src-dst-ip
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
IPv4: Source XOR Destination IP address
IPv6: Source XOR Destination IP address
Pull the cable between Gi6/6 and the Shaper. Now only Gi6/7 remains
in the bundle and all traffic traverses is port and through one PacketShaper
CompNet_CAT6509-2#sh etherchannel 1 sum
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Gi6/6(I) Gi6/7(P)