Can't Download iTunes.exe Through a ProxySG While ICAP Scanning on a ProxyAV or Content Analysis Appliance
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Can't Download iTunes.exe Through a ProxySG While ICAP Scanning on a ProxyAV or Content Analysis Appliance

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Article ID: 165504

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Updated On:

Products

ProxyAV Software - AVOS Content Analysis Software - CA ProxySG Software - SGOS

Issue/Introduction

Users cannot download iTunes.exe from apple.com while the ProxySG appliance performs ICAP scanning.

Cause

The problem occurs when the appliance sends the file for AV scanning, the file is big and the web page doesn't receive feedback in time, Apple.com download session timeout is shorter than the time scanning takes. 

Resolution

To resolve the issue:

  1. In the Management Console, select Configuration > Policy > Visual Policy Manager.
  2. In the Visual Policy Manager (VPM), select Policy > Add Web Content Layer.
  3. Accept or edit the layer name and click OK.
  4. Right click in Destination and select Set > New > Request URL.
  5. In the dialog that appears, select Simple Match and enter "apple.com" for the URL. 
  6. Click OK.
  7. Right click in Action and select Set > New > New ICAP Response Service.
  8. In the dialog that appears, select Do not use any ICAP response service and then click OK.

    The rule appears as follows in the VPM.
  9. Click Install Policy.

 Alternatively, instead of using the VPM, you can add the following CPL to the local policy file:

<Cache>
    url.domain=//apple.com/ response.icap_service(no)