ProxySG cannot access some HTTPS sites when using Internet Explorer on Windows 7
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ProxySG cannot access some HTTPS sites when using Internet Explorer on Windows 7

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Article ID: 165482

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Updated On:

Products

ProxySG Software - SGOS

Issue/Introduction

Some HTTPS websites do not load in Microsoft Internet Explorer when running Windows 7.

Cause

Internet Explorer is trying to use TLS 1.2 to connect to secure websites.

TLS 1.2 is not supported in SGOS 6.4.x or earlier. TLS 1.2 support for this feature is included in SGOS 6.5.x.

Note: This issue does not occur in Google Chrome and Mozilla Firefox because they re-negotiate the connection and try to use a different protocol (TLS 1.0 or 1.1, SSLv2 or v3).

 

Resolution

First, determine if the browser is trying to use TLS 1.2.

  1. Run a packet capture (PCAP) on the client and/or appliance.
  2. In the packet capture, find the secure connection coming from the client.
  3. Verify that the protocol being used is TLS 1.2.

If you have verified that TLS 1.2 is being used, disable TLS 1.2 in Internet Explorer.

  1. Open Internet Explorer and go to Internet options.
  2. On the Internet Options dialog, click Advanced.
  3. Under Settings, scroll down to Security.
  4. Clear the Use TLS 1.2 check box.
  5. Click OK.

HTTPS websites should load correctly after TLS 1.2 is disabled in Internet Explorer. You can run another PCAP to verify that TLS 1.2 is no longer being used.