401 error when downloading Content Filtering database on Edge SWG (ProxySG)
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401 error when downloading Content Filtering database on Edge SWG (ProxySG)

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Article ID: 165326

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Updated On:

Products

ProxySG Software - SGOS

Issue/Introduction

The Edge SWG (ProxySG) reports a 401 error when downloading the Bluecoat Webfilter (BCWF) content filtering database.

The download status shows the following error,

Download log:
  Blue Coat download at: 2009/07/31 03:46:56 +0800
  Downloading from https://list.bluecoat.com/bcwf/activity/download/bcwf.db
  Requesting differential update
  Fetching:
    https://list.bluecoat.com/bcwf/activity/download/bcwf.db?installed_version=292110400
      ERROR: HTTP 401 - Unauthorized
  Requesting full database
  Fetching:
    https://list.bluecoat.com/bcwf/activity/download/bcwf.db
      ERROR: HTTP 401 - Unauthorized
  Download failed

Environment

Edge SWG (ProxySG) running SGOS 6.7 configured to use Bluecoat WebFilter (BCWF).

Cause

The 401 error occurs because the credentials used for the download are not authorized to access the Content Filtering database.

Resolution

To resolve this issue, follow these steps:

  1. Access the Edge SWG (ProxySG) Management Console.
  2. Navigate to content filter download settings.
    • If you are using the SG Admin Console (SGAC), navigate to Administration > Data & Cloud Services > Content Filtering and edit the Blue Coat provider.
    • For the legacy Java Console, navigate to Configuration > Content Filtering > Blue Coat.
  3. Re-enter the content filtering credentials. To verify the credentials are correct, check the Broadcom entitlement portal.
  4. Download the database.

If the appliance still receives a 401 error, it's possible that your license has expired. Check your license contract or entitlement in the Broadcom entitlement portal for the expiration date.