SMA Agent upgrade fails with 'process is in use by another process' message
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SMA Agent upgrade fails with 'process is in use by another process' message

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Article ID: 165249

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Updated On:

Products

IT Management Suite

Issue/Introduction

When upgrading the Symantec Management Agent (SMA) via agent upgrade policy in the standard way, approx. 10% of agents fail to upgrade. 

Example error message in the agent log file:

Upgrade failed. Error message: Failed to run action: UninstallSurrogatesForX86 

process cannot access the file because it is being used by another process (0x00000020)

NOTE: the actual component that fails will vary and is not limited to the example above.

Environment

ITMS 7.6 HF7 upgrade to IMTS 8.x

Cause

The customer was using Red Cloak from Dell Secureworks which was locking files and preventing the upgrade. 

Resolution

On similar scenarios where our upgrade file is not accessible because another process is using it, try to identify what process it is.

One way is to use Process Explorer (from Microsoft's Sysinternals) in order to find out what process is locking our upgrade files. Some instructions in how to use Process Explorer for this, see this article.

In this particular instance, uninstalling the Red Cloak agent allowed the SMA Agents to upgrade successfully.