Software Update [xxx] has exceeded maximum reapplication retries (4)
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Software Update [xxx] has exceeded maximum reapplication retries (4)

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Article ID: 165222

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Updated On:

Products

Patch Management Solution for Windows Patch Management Solution IT Management Suite

Issue/Introduction

Software updates are failing to install, and the only message seen in the agent.log files is:

"Software Update [xxx] has exceeded maximum reapplication retries (4)"

Sample error is:
<event date='04/04/2017 13:05:07.0980000 -04:00' severity='4' hostName='<computer name>' source='SoftwareUpdateAgent' module='PatchMgmtAgents.dll' process='AeXNSAgent.exe' pid='5196' thread='5824' tickCount='72864229' >
  <![CDATA[Software update [Windows6.1-KB2891638-x64.msu] has exceeded maximum reapplication retries (4)]]>

Environment

ITMS 7.x. 8.x

Cause

When a software update initially fails to install on a managed computer the Patch Management Solution allows three more installation attempts.  
If all four installation attempts fail to install the update then this error message is returned.

Note:  The first three installation failures will display the failure code and message from the installer but once four installation failures occur the original message(s) are masked and replaced by "Software Update [xxx] has exceeded maximum reapplication retries (4)".

Resolution

The update that is failing to install needs to be identified.

Once the message "Software Update [xxx] has exceeded maximum reapplication retries (4)" is seen in the logs, you'll need to increase the reinstallation attempts to a number higher than the default of 3 to again be able to see the failure message.  
To do this:

  1. in the SMP Console, go to Settings > Agents/Plug-ins > All Agents/Plug-ins > Software > Patch Management > Windows > Default Software Update Plug-in Policy
  2. Under the "Installation Schedules" tab, under the schedules "Start/End dates" you'll see:

         Reinstallation attempts after task failure: 3

    Increase this value temporarily, while you are troubleshooting, to something like 10 or 15.  This will allow the installations to again attempt to run and you'll want to find the error message being returned and then troubleshoot what is causing this message.