Unable to load licenses from NS server. The request failed with HTTP status 403: Forbidden.
search cancel

Unable to load licenses from NS server. The request failed with HTTP status 403: Forbidden.

book

Article ID: 165211

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

While loading the licensing page under SIM (Add/Update Licenses), if SSL is required for the Default Web Site (Default Web Site>SSL Settings> Require SSL), the licensing page under SIM will not display the license counts.

Entry 1:

Initializing NSConfigurationWebService Url: http://<YourServername>.<yourdomain>.com/Altiris/NS/Services/LicensingWebService.asmx
--------------------------------------------------------------------------------------------------
Date: 4/25/2017 12:43:24 PM, Tick Count: 772468 (00:12:52.4680000), Size: 401 B
Process: SymantecInstallationManager (8312), Thread ID: 8, Module: SymantecInstallationManager.exe
Priority: 4, Source: Altiris.NS.Licensing.LicensingWebServiceProxy..ctor

Entry 2:

Unable to load licenses from NS server.
The request failed with HTTP status 403: Forbidden.
[System.Net.WebException @ System.Web.Services]
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Altiris.NS.Licensing.LicensingWebServiceProxy.GetLicenseStatus()
at Symantec.Installation.Model.LicenseManager.LoadLicensesFromServer.MoveNext()
at System.Collections.Generic.List'1..ctor(IEnumerable'1 collection)
at System.Linq.Enumerable.ToList[TSource](IEnumerable'1 source)
at Symantec.Installation.Model.LicenseManager.LoadFromServer(Func'1 getLicXml)
at Symantec.Installation.Model.LicenseManager.LoadLicenses(Boolean force)

Exception logged from:
at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
at Symantec.Installation.Model.LicenseManager.LoadLicenses(Boolean force)
at Symantec.Installation.Model.LicenseManager.RefreshLicenses(Boolean force)
at Symantec.Installation.Context.SimApplicationContext.ProductListingManager_LoadAndUpdateProductListingCompleteEvent(Object sender, CompleteEventArgs e)
at Symantec.Installation.Managers.ProductListingManager.LoadAndUpdateProductListings()
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()
--------------------------------------------------------------------------------------------------
Date: 4/25/2017 12:43:24 PM, Tick Count: 772484 (00:12:52.4840000), Size: 2.30 KB
Process: SymantecInstallationManager (8312), Thread ID: 8, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.Model.LicenseManager.LoadLicenses

Environment

ITMS 8.0
SIM 8.0 or later

Cause

This server originally was setup to use http (port 80) during the original implementation. Later on, HTTPS was implemented.
Some regkey entries needed to be adjusted for that change in order for SIM to properly call the right format in the desired pages. As the log entry above indicates, SIM was calling http://<YourServername>.<yourdomain>.com/Altiris/NS/Services/LicensingWebService.asmx rather than https://MySMPServer.yourdomain.com/Altiris/NS/Services/LicensingWebService.asmx

Resolution

Make the following changes in the registry:

  1. check the following regkeys:

    HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\NsConfiguration\NsWebSitePort
    HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\NsConfiguration\NsWebSiteSSL
     
  2. if NsWebSitePort is set to 80 and NsWebSiteSSL is set to False and you are currently using SSL, change them to 443 and True values respectively.
  3. Relaunch SIM and check the licensing page.