Active Directory Import tasks stay in a "Starting Import rule ...." state without performing any actual tasks
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Active Directory Import tasks stay in a "Starting Import rule ...." state without performing any actual tasks

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Article ID: 165099

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Updated On:

Products

IT Management Suite

Issue/Introduction

The AD Import rules are hanging at "Task is starting":

OR

  • The AD Import Rules just stay at 'Starting Import rule ....'.
  • Rebooting the Symantec Management Platform (SMP) servers or restarting services does not resolve the issue.
  • Clicking on the 'Stop Task' icon indicates Import task is stopping, but never actually comes to a stop.
  •  It is not possible to restart or stop the task.

AD import rule(s) in SMP display "Task is starting" status but the started and run time are excessive (Actions > Discover > Import Microsoft Active Directory).

The SMP a.log has the following entry for the rule:

Directory Import will not start, rule is already running: "<The import rule name>" <GUID>

- or -

Operation completed: Configuring directory import rule: 69173f10-1160-40f6-b780-1e92507b1f2a, total time=00:00:00.8209133
-----------------------------------------------------------------------------------------------------
Date: 11/16/2016 9:53:29 AM, Tick Count: 1553231375 (17.23:27:11.3750000), Size: 343 B
Process: AeXSvc (7144), Thread ID: 137, Module: AeXSVC.exe
Priority: 16, Source: DirectoryImportItem

Environment

ITMS 8.x

Cause

Possible corruption on the cache associated with the AD Import Rules.

Resolution

This issue has been addressed with ITMS 8.1 RU7 and  the AD Import internal task logic was switched from threads to .NET Task construct.

Previous workaround:

It is most likely that after reviewing the content of TaskManager table, these affected AD Import Rules will have a status of "R" which means retrying. As shown below:

when using query:

SELECT *
FROM TaskManager
WHERE State = 'R'

StartDateTime EndDateTime NumRestarts Name ClassName MethodName ErrorMessage PercentComplete ProgressDescription State Status Restartable Result
10:24.5 NULL 17 Directory Import Altiris.DirectoryServices.NSDirectoryItems.DirectoryImportTask DoDirectoryImportTask NULL 0 Task is starting... R 0 1 NULL
40:39.0 NULL 17 Directory Import Altiris.DirectoryServices.NSDirectoryItems.DirectoryImportTask DoDirectoryImportTask NULL 0 Task is starting... R 0 1 NULL
40:01.6 NULL 17 Directory Import Altiris.DirectoryServices.NSDirectoryItems.DirectoryImportTask DoDirectoryImportTask NULL 0 Task is starting... R 0 1 NULL

Please try the following steps:

  1. Stop Altiris Services
  2. Truncate TaskManager table
    • (Note: If you don't want to truncate the full table the following can also be used. Delete from TaskManager Where State = 'R')
    • truncate table taskmanager
  3. Clear out the user entry from UserSettings table.
    • delete from UserSettings
    • where ID= 'ASP.directoryimportrules_aspx_0b2cc377e2cf4bffad2bb02c1271507a' or ID= 'DC86E7223FB25A7D5B4162540DC6965E_0b2cc377e2cf4bffad2bb02c1271507a'
  4. Start Altiris Service
    1. Go to the AD Import Rules'Actions > Discover > Import Microsoft Active Directory' and run one of them using a Full or Update Import.