Cannot find message From: address in the Message Audit Logs of Messaging Gateway
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Cannot find message From: address in the Message Audit Logs of Messaging Gateway

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Article ID: 165003

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Updated On:

Products

Messaging Gateway

Issue/Introduction

When searching for a message in the Message Audit Logs, you may not be able to find the message using the From: address listed in your email client.

Cause

Email is similar to physical mail in that it is delivered in two parts, the envelope and the body. The envelope is transmitted between Message Transfer Agent (MTA)s and contains some basic information including the sender and the recipient. The body is what the end user email client displays and also includes all the message headers, including separate references to the sender and recipient(s).

The information in the body (including headers) of the message are not typically validated and can contain false information. The sender information in the envelope is generally more trusted; though it can also contain false information, it may be validated by the MTAs.

Due to the level of trust, the Messaging Audit Logs list the envelope sender rather than the body sender. As such, searching for the From: address found in the email client or message body headers may not return any results.

Resolution

To search for a specific message in Message Audit Logs, it is best to search using the Message-Id or X-AuditId that are found in the message headers. These two fields are much more reliable for tracking down specific messages. Viewing the message headers varies by vendor, but is typically done by reviewing the message properties or the message source.