VIETool fails to act on most files when Unidesk is installed to the client
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VIETool fails to act on most files when Unidesk is installed to the client

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Article ID: 164996

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Updated On:

Products

Endpoint Protection

Issue/Introduction

When running the VIETool that is included with Symantec Endpoint Protection on a Unidesk volume, it appears that the VIETool is not taking action on files when expected to.

The nm_tool_service.log shows errors.
For example:

9/2/2011 3:05:03 PM: Adding bit to c:/Windows/ehome/ehtray.exe
9/2/2011 3:05:03 PM ERROR: Failed to set bit for c:/Windows/ehome/ehtray.exe

Environment

Unidesk managed VDI environment

Cause

After active collaboration of engineering efforts between Symantec and Unidesk, both vendors came to the conclusion that VIETool and Unidesk volumes are not compatible.

Symantec’s methods of determining what files need to be scanned or skipped with the VIETool is not compatible with the way Unidesk creates and maintains readable and writeable volumes. In order to make them compatible, both products would require major design changes in the way the volumes are created and managed by Unidesk and how Symantec identifies what needs to be scanned.

Resolution

It is not recommended to use the VIETool on Unidesk volumes due to this incompatibility.