Large memory leak in the AeXNSAgent process, immediately hits 25 to 30% CPU, consumes up to 4 GB memory
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Large memory leak in the AeXNSAgent process, immediately hits 25 to 30% CPU, consumes up to 4 GB memory

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Article ID: 164959

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Updated On:

Products

IT Management Suite

Issue/Introduction

When the Symantec Management Agent service starts, it consumes 25% of the CPU, and Memory usage quickly hits 1 GB, then climbs up to between 3.5 to 4.5 GB. On systems with limited memory it can crash the operating system.

Cause

Known issue
A stored procedure was missing a Distinct call, resulting in way too many results for Application Metering policy components to meter.

Resolution

A fix is in the works by Symantec Development.
To work around the issue, follow these steps:

  1. Open SQL Enterprise Studio and connect to the Symantec_CMDB database.
  2. Run the following query:

    USE [Symantec_CMDB] --If name is different, change this)
    GO
    /****** Object:  StoredProcedure [dbo].[spGetSoftareComponentMeteringInfo]    Script Date: 03/28/2017 12:59:57 ******/
    SET ANSI_NULLS ON
    GO
    SET QUOTED_IDENTIFIER ON
    GO
    ALTER PROCEDURE [dbo].[spGetSoftareComponentMeteringInfo]
        AS
                  BEGIN
          select distinct se._ResourceGuid, wf.Name, wf.InternalName, wf.ProductName, wf.ProductVersion, wf.FileVersionString from Inv_Software_Execution se
          join vWindowsFile wf on wf.Guid=se._ResourceGuid
          where se.IsMetered=1
        END
  3. Then execute from windows scheduler “NS.Hourly schedule to update SBUT policy.{2717bd64-52a7-4faf-bdfd-e6a81e0200b6}” Task