Software Updates fail with Exit Code 31
search cancel

Software Updates fail with Exit Code 31

book

Article ID: 164921

calendar_today

Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Reviewed recent changes in PMImport v7.2.x; found all Software Updates fail with Exit Code 31 during the Software Update Cycle.

Exit Code 31

Environment

Patch Management 7.5.x, 7.6.x and 8.x

Cause

Found HKEY_CLASSES_ROOT\TypeLib\{6D6961DE-9B0E-433F-9743-119447B5653D}\1.0\0 registry existed for Win32 pointing to a non-existent file at C:\Program Files (x86)\Altiris\Altiris Agent\Agents\SoftwareManagement\smfagent.dll

Additionally, found a one-off situation where the Symantec Management Agent had become corrupt within the environment.

Resolution

This issue was resolved in PMImport v7.2.25 released on 5/4/17: Includes updated files to fix this issue.

Workaround:

  • RDP to the affected Client
  • Delete the registry key: HKEY_CLASSES_ROOT\TypeLib\{6D6961DE-9B0E-433F-9743-119447B5653D}\1.0\0\Win32
  • Allow the Windows System Assessment Scan to complete 

Additional workaround if removing registry above fails to resolve in a one-off situation:

  • Enable the Symantec Management Agent for Windows Uninstall​ policy:
    • Found on the Console > Settings > Agents/Plug-ins > Symantec Management Agent > Windows; enable and target required Clients
  • Deploy the Symantec Management Agent for Windows:
    • Found on the Console > Settings > Agents/Plug-ins > Symantec Management Agent > Settings > Agent Install; target the filter or Add computers to the select computers and deploy