Symantec Management Agent not getting registered
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Symantec Management Agent not getting registered

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Article ID: 164730

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Updated On:

Products

IT Management Suite

Issue/Introduction

Symantec Management Agent is not getting registered on any computer including SMP. There is no error in logs but the status keeps coming as pending like this:

An attempt to register on Task Server [SMP-ServerName.domain] over [http] completed with status [PENDING].

Environment

ITMS 8.x

Cause

The Altiris Client Task Data Loader (ctdataloader) and Altiris Object Host Service (AtrsHost) services were set to run with the Application Identity account manually.

Resolution

In this scenario, the ​Application Identity account password was changed and the Altiris Client Task Data Loader (ctdataloader) and Altiris Object Host Service (AtrsHost) services were changed to run with Application Identity account manually. Change them to Log On as "Local System account" and restarted both the services. Then restarted the Symantec Management Agent (AeXNSClient) service, this attempted to register both services and it worked successfully.

Note: It is recommended to follow the steps in KB 156852 for changing the Application Identity account password for the Notification Server.