Errors in the SMP logs state while trying to process NSEs: Target item for the client message does not exist
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Errors in the SMP logs state while trying to process NSEs: Target item for the client message does not exist

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Article ID: 164721

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Updated On:

Products

Client Management Suite IT Management Suite Server Management Suite

Issue/Introduction

Errors in the SMP logs state while trying to process NSEs: Target item for the client message does not exist.

The following error entries (both or just one of them) can be seen in a consistent way in the NS logs :

Entry 1:

NSE dispatch failed for: id=131376356, from: 05329b69-89d9-48d5-a103-1234e6827f39, to: 7cc06486-dd1e-41a0-942a-bce8a33c3deb

The target item for the client message has been deleted in NS: from: 05329b69-89d9-48d5-a103-1234e6827f39, to: 7cc06486-dd1e-41a0-942a-bce8a33c3deb 


OR like this one:

NSE dispatch failed for: id=131375623, from: 87310503-110d-4791-9550-cd62b7c44d83, to: 2ee29254-57ae-4291-b297-957b02bf8250

The target item for the client message does not exist: from: 87310503-110d-4791-9550-cd62b7c44d83, to: 2ee29254-57ae-4291-b297-957b02bf8250  

 

NSE dispatch failed for: id=131376356, from: 05329b69-89d9-48d5-a103-1234e6827f39, to: 7cc06486-dd1e-41a0-942a-bce8a33c3deb

The target item for the client message has been deleted in NS: from: 05329b69-89d9-48d5-a103-1234e6827f39, to: 7cc06486-dd1e-41a0-942a-bce8a33c3deb
   [Altiris.NS.ClientMessaging.UnresolvableHandlerException @ Altiris.NS]
   at Altiris.NS.ClientMessaging.EventQueueDispatcher.DispatchWithinContext(Int32
eventQueueId, String message, Boolean useFilename, Int64 fileSize, Int64
eventId, MessageHeader header)
   at Altiris.NS.ClientMessaging.EventQueueDispatcher.TryDispatch(Int32
eventQueueId, String message, Boolean useFilename, Int64 fileSize, Int64
eventId)

Exception logged from:
   at Altiris.NS.ClientMessaging.EventQueueDispatcher.TryDispatch(Int32,
String,
Boolean, Int64, Int64)
   at Altiris.NS.ClientMessaging.EventQueueDispatcher.PerformDispatch(Altiris.NS.ClientMessaging.EventQueueDispatcher+DispatchSlot, Boolean&)
   at Altiris.NS.ClientMessaging.EventQueueDispatcher.WorkerDispatchStep(Altiris.NS.ClientMessaging.EventQueueDispatcher+DispatchSlot, Altiris.Common.Threading.IAutoCallContextSnapshot)
   at Altiris.NS.ClientMessaging.EventQueueDispatcher.DispatchSlotThreadProc(Object)
   at System.Threading.ThreadHelper.ThreadStart(Object)

--------------------------------------------------------------------------------

Date: 7/17/2019 12:56:33 PM, Tick Count: 71000906 (19:43:20.9060000), Size: 1.61 KB
Process: AeXSvc (1608), Thread ID: 418, Module: Altiris.NS.dll
Priority: 1, Source: Altiris.NS.ClientMessaging.EventQueueDispatcher.TryDispatch

OR like this one:

NSE dispatch failed for: id=131375623, from: 87310503-110d-4791-9550-cd62b7c44d83, to: 2ee29254-57ae-4291-b297-957b02bf8250

The target item for the client message does not exist: from: 87310503-110d-4791-9550-cd62b7c44d83, to: 2ee29254-57ae-4291-b297-957b02bf8250
   [Altiris.NS.ClientMessaging.UnresolvableHandlerException @ Altiris.NS]
   at Altiris.NS.ClientMessaging.EventQueueDispatcher.DispatchWithinContext(Int32 eventQueueId, String message, Boolean useFilename, Int64 fileSize, Int64
eventId, MessageHeader header)
   at Altiris.NS.ClientMessaging.EventQueueDispatcher.TryDispatch(Int32 eventQueueId, String message, Boolean useFilename, Int64 fileSize, Int64 eventId)

Exception logged from:
   at Altiris.NS.ClientMessaging.EventQueueDispatcher.TryDispatch(Int32,
String, Boolean, Int64, Int64)
   at Altiris.NS.ClientMessaging.EventQueueDispatcher.PerformDispatch(Altiris.NS.ClientMessaging.EventQueueDispatcher+DispatchSlot, Boolean&)
   at Altiris.NS.ClientMessaging.EventQueueDispatcher.WorkerDispatchStep(Altiris.NS.ClientMessaging.EventQueueDispatcher+DispatchSlot, Altiris.Common.Threading.IAutoCallContextSnapshot)
   at Altiris.NS.ClientMessaging.EventQueueDispatcher.DispatchSlotThreadProc(Object)
   at System.Threading.ThreadHelper.ThreadStart(Object)


--------------------------------------------------------------------------------
Date: 7/17/2019 12:51:51 PM, Tick Count: 70718812 (19:38:38.8120000), Size: 1.60 KB
Process: AeXSvc (1608), Thread ID: 418, Module: Altiris.NS.dll
Priority: 1, Source:
Altiris.NS.ClientMessaging.EventQueueDispatcher.TryDispatch

Environment

All versions of Symantec Management Platform

Cause

If the following entry is noticed:

NSE dispatch failed for: id=131376356, from: 05329b69-89d9-48d5-a103-1234e6827f39, to: 7cc06486-dd1e-41a0-942a-bce8a33c3deb

The target item for the client message has been deleted in NS: from: 05329b69-89d9-48d5-a103-1234e6827f39, to: 7cc06486-dd1e-41a0-942a-bce8a33c3deb 

usually means that there is a package that was deleted on the SMP but client machines still have a reference of it. Actively used Software Management Policies are not being disabled before being deleted.

Altiris Agent keeps a record of what Policies it has active, and when it reports back to the NS on these policies, the error will occur if the item referred to no longer exists in the database.

If you open one of those NSEs, you may noticed somethig like this:

              <SWDStatusEvent src="Altiris.SWD">

                             <Time>20190719131109.522000+240</Time>

                             <Type>Package Removed</Type>

                             <PackageId>{27A63E62-0049-9F43-AB35-80562ED9B6D9}</PackageId>

                             <JobId>{6D6E3270-2F42-4B7A-9ED9-F43BFFCB6C7A}</JobId>

                             <PackageName>excel2016-kb4462236-fullfile-x86-glb.exe</PackageName>

                             <AdvertisementName>excel2016-kb4462236-fullfile-x86-glb.exe for PMP-042019-All</AdvertisementName>

                             <ProgramName>excel2016-kb4462236-fullfile-x86-glb.exe for PMP-042019-All</ProgramName>

                             <Status>Package no longer required.</Status>

                             <Message></Message>

              </SWDStatusEvent>


If you see this other message:

NSE dispatch failed for: id=131375623, from: 87310503-110d-4791-9550-cd62b7c44d83, to: 2ee29254-57ae-4291-b297-957b02bf8250

The target item for the client message does not exist: from: 87310503-110d-4791-9550-cd62b7c44d83, to: 2ee29254-57ae-4291-b297-957b02bf8250  

usually means that there is events coming from an Agent Plugin for a Solution that is not longer installed on the SMP.
The "From" line refers the GUID of the machine sending the event.

Resolution

This issue has been reported to our Symantec Development team. A fix has been added to ITMS 8.5 RU2 release in regards packages that no longer exists in the SMP.

Recommendation: Always Disable policies for several days (minimum of 1 agent Update Configuration cycle which is usually 1-4 hours) before deleting Software Management Policies.  Only delete Software Packages from the Software Library after the Policy has been disabled at least one Update Configuration cycle.

For log entries referring to "The target item for the client message does not exist", you may need to check some of those machines sending the NSEs and see if they have plugins installed for Solutions no longer installed in the SMP.