GC (Garbage Collection) overhead limit exceeded error encountered in Messaging Gateway when attempting to save configuration.
search cancel

GC (Garbage Collection) overhead limit exceeded error encountered in Messaging Gateway when attempting to save configuration.

book

Article ID: 164700

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

When trying to save configuration changes, which also publishes the changes to scanners, you encounter an error that prevents the configuration changes from being published to all scanners.
 

The primary failure error message looks like:

Attempt to publish configuration generates out of memory condition in log:
Feb 10 2017 16:12:37 [PublishingThread-147] [PublisherJob] ERROR - can't publish configuration to host: 
svodlpmail04.ds.ohnet
java.lang.OutOfMemoryError: GC overhead limit exceeded 

Followed by:

Feb 10 2017 16:13:14 [http-bio-443-exec-17] [ExceptionHandler] ERROR -
com.symantec.smg.controlcenter.host.publishing.PublishingException: Configuration saved successfully but could not 
publish configuration to the following hosts - [scanner host]. Please check control center logs for details. 

For this issue, the BrightmailLog.log is also filled with many references similar to the following error:

Feb 10 2017 09:04:30 [BrightmailScheduler_Worker-30] [MailTransferEventManager] WARN - the number of mail transfer 
events exceeded the maximum value of 1000000 events. deleted 1041 events.

Cause

This error can arise due to Symante Protection Center (SPC) integration, when the SPC server is not communicating with the Symantec Messaging Gateway (SMG). The data that should be collected and purged by the SPC process instead accumulates and causes memory and process overhead to SMG.

Resolution

Correct the communication issues between SMG and SPC. Otherwise, use the SPC administration functions to deregister SMG integration. Refer to the SPC documentation for information on deregistration.

If the SPC server is unavailable, the delete command can be used from the command line login on the Control Center to remove SPC configuration information:

  1. Login to the command line of the Control Center with the default admin account.
  2. Run the delete command for SPC data:
    • delete spcdata

From the delete help information:

> delete
Usage: delete [--purge <num>] <component> [<component ...>]
       delete file <file>

...

Data components:
...
   spcdata        Delete all Symantec Protection Center (SPC) related data.
                  Afterwards, you will need to re-register the Control Center
                  with the SPC server if you wish to continue using the
                  Control Center with SPC.
...