When SIM is trying to launch, the following error occurs: Uncaught Exception in Application. Not found. code=NotFound (0x80041002)
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When SIM is trying to launch, the following error occurs: Uncaught Exception in Application. Not found. code=NotFound (0x80041002)

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Article ID: 164687

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Updated On:

Products

IT Management Suite

Issue/Introduction

The customer is unable to open SIM. When attempting to open SIM, it fails out immediately with an unexpected exception.
The SIM logs show: 

Uncaught Exception in Application
Not found
....

Management Exception details: code=NotFound (0x80041002)

 

Uncaught Exception in Application
Not found

[System.Management.ManagementException @ System.Management]
at System.Management.ManagementScope.Initialize()
at System.Management.ManagementObjectSearcher.Initialize()
at System.Management.ManagementObjectSearcher.Get()
at Symantec.Installation.EnvironmentInfo.GetProcessorArchitecture()
at Symantec.Installation.ProductFilter.GetCurrentPlatform()
at Symantec.Installation.Managers.ProductListingManager..ctor(SimApplicationContext context)
at Symantec.Installation.Context.SimApplicationContext..ctor()
at Symantec.Installation.Context.SimApplicationContext.CreateContext()
at Symantec.Installation.SimApplication.Main(String[] args)

Management Exception details: code=NotFound (0x80041002)

Exception logged from:
at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
at Symantec.Installation.SimApplication.Main(String[] args)
--------------------------------------------------------------------------------
Date: 2/21/2017 3:44:11 PM, Tick Count: 222028220 (2.13:40:28.2200000), Size: 1.39 KB
Process: SymantecInstallationManager (4700), Thread ID: 1, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.SimApplication.Main

Environment

ITMS 7.5 SP1 and later
 

Cause

This error is environmental. Usually "0x80041002 (WBEM_E_NOT_FOUND)" error occurs when you try to open a WMI namespace on a computer that is running Windows 7 or Windows Server 2008 R2.
This issue occurs because the WMI repository is corrupted.
The WMI service does not correctly handle an item deletion operation for the WMI repository. This behavior causes the index tree of the WMI repository to become corrupted. Therefore, you experience the error that is described in "Symptoms" section when you try to open a namespace.

Resolution

This issue is described by Microsoft and a hotfix is provided by them here:

https://support.microsoft.com/en-us/help/2465990/-0x80041002-wbem-e-not-found-error-occurs-when-you-try-to-open-a-wmi-namespace-on-a-computer-that-is-running-windows-7-or-windows-server-2008-r2

To validate the issue,

  1. Go to Control Panel -> Administrative Tools -> Computer Management. In the left-hand pane, click Services & Applications -> WMI Control, right-click and select Properties. If you see a window like this:

  2. Then the WMI repository is corrupted (if you see your processor and version of Windows listed, the WMI repository may still be corrupted but is at least partially working).
  3. Note: If the Microsoft hotfix mentioned above doesn't work and WMI is still corrupted, please try the following commands from the Command Prompt running as Administrator:
    winmgmt /verifyrepository
    winmgmt /salvagerepository

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