Servicedesk 8.0 HF6 displays Error in Log "[FileNotFoundException]: Could not load file or assembly 'LogicBase.Framework, Version=8.1.3344.0"
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Servicedesk 8.0 HF6 displays Error in Log "[FileNotFoundException]: Could not load file or assembly 'LogicBase.Framework, Version=8.1.3344.0"

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Article ID: 164678

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Updated On:

Products

ServiceDesk

Issue/Introduction

After installing Servicedesk 8.0 HF6, and attempting to create an incident, the screen displays an error.  Upon opening the logviewer, the following error was displayed. The incident was not created.

Application Name : SD.IncidentManagementSimple.EndUserRequest
Process ID : 1500
Date :2/21/2017 8:36:40 PM
Log Level :Error
Log Category :LogicBase.Components.Default.Logging.CreateLogEntryComponent
Machine Name : SDWF80
Message : 
An error has occured:
 
Exception in component: Submit Incident
 
Exception Message:
Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.
The request failed with the error message:
--
<!DOCTYPE html>....

<b> Description: </b>An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

            <br><br>

            <b> Parser Error Message: </b>Could not load file or assembly 'LogicBase.Framework, Version=8.1.3344.0, Culture=neutral, PublicKeyToken=307367a36958bdad' or one of its dependencies. The system cannot find the file specified.<br><br>

            <b>Source Error:</b> <br><br>

            <table width=100% bgcolor="#ffffcc">
               <tr>
                  <td>
                      <code><pre>

Line 19:     <compilation defaultLanguage="c#" debug="false">
Line 20:       <assemblies>
<font color=red>Line 21:         <add assembly="LogicBase.Framework, Version=8.1.3344.0, Culture=neutral, PublicKeyToken=307367a36958bdad" />
</font>Line 22:         <add assembly="Symantec.ProcessManager.WebServiceProxies, Version=8.1.3344.0, Culture=neutral, PublicKeyToken=307367a36958bdad" />
Line 23:         <add assembly="LogicBase.Core, Version=8.1.3344.0, Culture=neutral, PublicKeyToken=307367a36958bdad" /></pre></code>

                  </td>
               </tr>
            </table>

            <br>

            <b> Source File: </b> C:\Program Files\Symantec\Workflow\WorkflowDeploy\Release\SD.IncidentManagementSimple\web.config<b>    Line: </b> 21
            <br><br>

            <b>Assembly Load Trace:</b> The following information can be helpful to determine why the assembly 'LogicBase.Framework, Version=8.1.3344.0, Culture=neutral, PublicKeyToken=307367a36958bdad' could not be loaded.<br><br>

            <table width=100% bgcolor="#ffffcc">
               <tr>
                  <td>
                      <code><pre>

WRN: Assembly binding logging is turned OFF.

Environment

Servicedesk Incident Management  8.0 HF6

Cause

Incorrect references to the LogicBase.Framework assembly in the SD.IncidentManagementSimple web.config file 

Resolution

Symantec is planning to resolve this in an updated release of the 8.0 HF6 installer for Servicedesk.  Until that time, this can be resolved in the following two ways:

Method A:

  1. Browse to ..:\Program Files\Symantec\Workflow\WorkflowDeploy\Release\SD.IncidentManagementSimple
  2. Open the web.config file in Notepad
  3. Search and replace any instances of "8.1.3344.0", with "8.0.3705.0"
  4. Save the File and restart services.

Method B:

  1. Execute the attached installer on the Servicedesk server.  

 

Attachments

SD.IncidentManagementSimple.Setup.exe get_app