Upgrade of DLP Endpoint agent is failing with "Installation success or error status: 1603" error.
search cancel

Upgrade of DLP Endpoint agent is failing with "Installation success or error status: 1603" error.

book

Article ID: 164654

calendar_today

Updated On:

Products

Data Loss Prevention Endpoint Prevent

Issue/Introduction

Upgrade of current DLP Endpoint agent to a next major release is failing with "Installation success or error status: 1603" error.

You are seeing below mentioned lines in the upgrade log file:

MSI (s) (44:D8) [16:02:45:451]: Windows Installer installed the product. Product Name: AgentInstall64. Product Version: 14.0.2000.01056. Product Language: 1033. Manufacturer: Symantec Corp.. Installation success or error status: 1603.

2017-01-09 16:02:45 | CreateContentStoreWithLegacyItem | FINEST | RegEnumKeyEx() returned: 259
2017-01-09 16:02:45 | CreateContentStoreWithLegacyItem | FINEST | strCurProdID: 00002105501100000000000000F01FEC
2017-01-09 16:02:45 | CreateContentStoreWithLegacyItem | FINEST | UninstallString value not found for this key.
2017-01-09 16:02:45 | CreateContentStoreWithLegacyItem | FINEST | strCurProdID: 00002109210000000000000000F01FEC
2017-01-09 16:02:45 | CreateContentStoreWithLegacyItem | FINE | UninstallString: MsiExec.exe /X{90120000-0012-0000-0000-0000000FF1CE}
2017-01-09 16:02:45 | CreateContentStoreWithLegacyItem | FINEST | Uninstall string did not match product code.
2017-01-09 16:02:45 | CreateContentStoreWithLegacyItem | FINEST | strCurProdID: 00002109511090400000000000F01FEC
2017-01-09 16:02:45 | CreateContentStoreWithLegacyItem | FINE | UninstallString: MsiExec.exe /X{90120000-0115-0409-0000-0000000FF1CE}
2017-01-09 16:02:45 | CreateContentStoreWithLegacyItem | FINEST | Uninstall string did not match product code.
2017-01-09 16:02:45 | CreateContentStoreWithLegacyItem | WARNING | findProductId() failed

Environment

Windows 7, Windows 10

Cause

This issue is caused if below mentioned string values are missing from windows registry hive:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{Product ID}

Note: For DLP 12.5 Endpoint Agent, the above mentioned product ID is going to be B29DE059-FEC4-4304-96BB-50308729BEDE

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\Product ID\InstallProperties

Note: For DLP 12.5 Endpoint Agent, the above mentioned product ID is going to be 950ED92B4CEF403469BB05037892EBED

Please consult DLP Technical support to find out relevant Product ID's

 

Resolution

  1. Open HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{B29DE059-FEC4-4304-96BB-50308729BEDE}
  2. Right click on the right hand side of the regedit window, click “New”, click “String” and name the new string as UninstallString
  3. Right click UninstallString, click Modify and enter the value as MsiExec.exe /X{Product ID}
  4. Open HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\Product ID\InstallProperties
  5. Right click on the right hand side of the regedit window, click “New”, click “String” and name the new string as UninstallString
  6. Right click UninstallString, click Modify and enter the value as MsiExec.exe /X{Product ID}
  7. Reboot the machine and then try upgrading DLP Endpoint Agent again