Application error occurs when saving a command configuration in a Generic Devices Data Collector check in a CCS standard
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Application error occurs when saving a command configuration in a Generic Devices Data Collector check in a CCS standard

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Article ID: 164624

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Updated On:

Products

Control Compliance Suite Windows

Issue/Introduction

In Control Compliance Suite 11.5.1, when creating a Generic Devices check, an Application error occurs, after entering information in the "Command" tab (in the "Name" and "Command Details" sections) and then attempting to save it.

The application has encountered a problem.
Following are the application messages that are logged when the problem occurred:
The most recent message is listed first.

* The creator of this fault did not specify a Reason.

--- Application Execution History ---

Server stack trace: 
   at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]: 
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at Symantec.CSM.Standards.PublishedInterface.ServiceContracts.ICommandService.Create(Command command, Boolean createWithUniqueNameIfExists)
   at Symantec.CCS.ConsoleBusiness.Standards.PanelData.CommandPanelData.Update(IEvaluationObject evaluationObject, Boolean& isUpdated)
   at Symantec.CCS.ConsoleBusiness.Standards.PanelData.CheckPanelData.UpdatedCheckObject()
   at Symantec.CCS.Console.Standards.PreviewPanelController._save()
   at Symantec.CCS.Console.Standards.PreviewPanelController.Save()

Some errors like the following may also be seen in the application server service logs:

"Error occured while auditing Command Create method : System.Transactions.TransactionManagerCommunicationException: Network access for Distributed Transaction Manager (MSDTC) has been disabled. Please enable DTC for network access in the security configuration for MSDTC using the Component Services Administrative tool. ---> System.Runtime.InteropServices.COMException: The transaction manager has disabled its support for remote/network transactions. (Exception from HRESULT: 0x8004D024)

Environment

CCS 11.5.1 (PU 2016-3) with SCU 2016-3.

Cause

The issue is related to a failure of proper transactions between distributed machines, using Microsoft Distributed Transaction Coordinator (MS DTC).

Resolution

The solution may involve one or more of the following:

1. If Windows Firewall enabled, you must configure the computer to allow DTC traffic through the firewall (port 135).

2. Configure Microsoft DTC security settings to allow transaction communication, for inbound and outbound, on both the SQL server and on the application server systems:

  • In Administrative Tools, open "Component services" (or run the command dcomcnfg)
  • In the console tree, click to expand Component Services, click to expand Computers, click to expand My Computer, click to expand Distributed Transaction Coordinator and then right-click "Local DTC".
  • Select "Properties" to display the Local DTC Properties dialog box.
  • Click the Security tab.
  • Check the box for "Network DTC Access".
  • Check the boxes for "Allow Inbound" and "Allow Outbound".
  • Click Apply, OK.
  • A message will pop up about restarting the MSDTC service. Click OK.

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