KNOWN ISSUE: Double byte lang (Japan, Korean, etc.) modified with Western Euro languages (German, French, etc.) appear incorrectly
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KNOWN ISSUE: Double byte lang (Japan, Korean, etc.) modified with Western Euro languages (German, French, etc.) appear incorrectly

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Article ID: 164468

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Updated On:

Products

Symantec Products

Issue/Introduction

On a machine with Japanese multi-user interface support installed:

1. Add German to the .WSI project.
2. Save and compile.
3. Add Japanese then save and compile.
4. On the Dialogs tab of SetupEditor, note that German characters all appear correct, but the Japanese characters do not display correctly - this is all right at this point.
5. Using the Regional and Language options applet, set Japanese to be the language for non-unicode programs.
6. After the machine reboots, open the .WSI again.

The Japanese characters are fine, but some of the German letters are incorrect.

7. Reset the non-unicode language to English (US).
8. After reboot, open the .WSI.

Some German characters are still not correct.

Cause

This is caused by the Codepage that is used for the Western European languages in our Language Pack. All of the Western European languages are set to use a codepage of 0, which is a neutral code page. However, when the machine also has support for double byte languages, some of the Western European characters are not displayed correctly when using codepage 0.

Resolution

Workaround:

If you have a new .WSI or a .WSI that has not been saved on a machine that has support for double byte languages:
  1. Go to Installation Expert > Languages page
  2. Double-click on the language that contains extended characters that are not displaying correctly
  3. Select the appropriate Codepage from the Codepage drop-down list. For a list of codepage for various languages, please see the Windows Installer SDK topic 'Localizing the Error and ActionText Tables'. Click OK.
  4. Mark the checkbox to add that language to your installation
  5. Compile your .WSI

If the installation was created or saved on a machine that has double byte languages, the language text strings need to be re-imported. This can be accomplished by performing the following:

  1. Go to Installation Expert > Languages page and make note of each language that is selected. This is necessary for step 4 when modifying the tables.
  2. Go to Setup Editor > Tables tab
  3. Select the WiseLanguage table
  4. For each row that has a value other than 0 in the AttributesEx column, perform the following (These steps reset the language so that they appear to be untranslated):
    a) If the language was selected on the Languages page, subtract 1 from the current value in the Attributes column. The currently existing value should be an odd number. If it is not, verify that it is checked on the Languages page. For example, if German is selected, the value in the Attributes column should currently be 1. Change this value to 0.
    b) Change the value in the AttributesEx column to 0.
  5. Go back to the Installation Expert > Languages page. At this point, all the languages should be unmarked and the Text Translated column should be 'No' for all languages.
  6. Double-click on the language that contains extended characters that are not displaying correctly
  7. Select the appropriate Codepage from the Codepage drop-down list. For a list of codepage for various languages, please see the Windows Installer SDK topic 'Localizing the Error and ActionText Tables'. Click OK.
  8. Mark the checkbox to add that language to your installation
  9. Compile your .WSI

Applies To
Wise For Windows Installer 5.21
Wise For Windows Installer 6.X
Wise Installation Studio 7.X
Wise Package Studio 7.X