Auto Upgrade to Endpoint Protection 14.x Clients fail from Endpoint Protection Manager
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Auto Upgrade to Endpoint Protection 14.x Clients fail from Endpoint Protection Manager

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Article ID: 164365

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Updated On:

Products

Endpoint Protection

Issue/Introduction

When Auto Upgrade performed from Endpoint Protection Manager (SEPM), some Endpoint Protection Client (SEP) have been upgraded to SEP 14 successfully while the rest clients failed.

SEP Client Sylink Debug log:

11:34:22=>HTTP REQUEST sent
<SendUrlAndReceiveResponse:>SMS return=469
<ParseHTTPStatusCode:>469=>469 CONTENT PENDING
<IndexHeartbeatProc>Agent Package Content pending - Accelerating Heartbeat.. 

SEPM scm-server.log(table switch):

11:40:11.819 THREAD 146 WARNING: Log table switched to: AGENT_TRAFFIC_LOG_1, old table estimated row count: 50322, to add row count in new table: 983, last switch time:  10:59:16

Cause

By checking SEPM folder (...\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\Inetpub\ClientPackages\#############\FULL), full Clientpackage file size is less than it should be (~80mb), but xdelta file size is a lot larger. SEPM server was not able to create delta upgrade package to SEP clients

Resolution

  1. Backup SEPM database
  2. Remove upgrade package which has been added into SEP group(Clients--Client Group--Install Packages)
  3. Delete SEP old install package from SEPM console(Admin-- Install package--client install package), this action is to delete SEP old package for 32 and 64 bits on SEPM console.
  4. Check if below folder was deleted (related folder should be deleted accordingly):
    ...\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\Inetpub\ClientPackages\
  5. Then open setup.ini and confirm there is no old package(such as both 12.1.7061.6600 32 and 64 bits):
    For example, ...\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\Inetpub\ClientPackages\#############\FULL\setup.ini
    CmdLine=/l*v "%TEMP%\SEP_INST.log" IDCENABLE=0
    ProductName=Symantec Endpoint Protection
    ProductCode={#############.EN_US}
    ProductVersion=12.1.7061.6600
    PackageName=Sep64.msi
    PackageCode={#############.EN_US}
  6. Stop SEPM services and find 14.0 version package folder, and delete all xdelta#### file except FULL folder Full.ZIP full.zip.sig
  7. Navigate to this path and double confirm the setup.ini file if it is version14:
    ...\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\Inetpub\ClientPackages\<VersionGUID>\
  8. Start SEPM services and add SEP 14 package to Client Group refer to Step 2.