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CIS RHEL 5 standard error "index was outside the bounds of the array" for /etc/passwd checks

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Article ID: 164070

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Updated On:

Products

Control Compliance Suite Windows

Issue/Introduction

CIS Benchmark v1.1.2 for Red Hat Enterprise Linux 5.0 and 5.1  checks for "No duplicate uids exist in /etc/passwd?" and "No duplicate usernames exist in /etc/passwd?" giving Array error only on some RHEL 5.x targets.

 

Failed evaluating Custom Algorithm - Symantec.CSM.UnixPlatformContent.RHELv1.0.5.dll;Symantec.CSM.UnixPlatformContent.RHEL.DubplicatesFromFile. Message - Index was outside the bounds of the array.. Stack Trace - at System.Array.InternalGetReference(Void* elemRef, Int32 rank, Int32* plndices) at System.Array.GetValue(int32 index) at Symantec.CSM.UnixPlatformContent.RHEL.DuplicatesFromFile.Execute(IParamters parameters, ITargetData targetData, Evidence checkEvidence) at Symantec.EvaluationEngine.ProcedureEvaluator.EvaluateCustomeAlgorithm(IProcedureReference refer)

Environment

CCS 11.0 and 11.5

Cause

Incorrectly formatted entries in /etc/passwd file.  Issue possibly caused by cutting and pasting information into the file, introducing errors.  Issues such as carriage returns interrupting the entries and forcing them into separate lines can cause this error.

Resolution

Check the /etc/passwd file for incorrect entries.  In particular look to see if carriage returns have been inappropriately entered in the middle of a line for an account.  This will cause the array out of bound issue.  Correct the format of the passwd file entries and the array error should be resolved.