Monitor Solution Help (Help>Context) is not working: The "product" value in the URL is missing or invalid
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Monitor Solution Help (Help>Context) is not working: The "product" value in the URL is missing or invalid

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Article ID: 163663

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Updated On:

Products

IT Management Suite Monitor Solution

Issue/Introduction

Customer is unable to load the Unified Help System (UHS) context (Help>Context) for one of the Solutions.
In this last particular case it doesn’t work for the items under Monitor Solution (or at least from the Policies page when accessing monitoring policies created under Windows Server Health for example). The link that is generated is like this:

http://SMPServer.domain.local:8080/unifiedhelp/#/error?vid=RuleLibrary&product=Mon&context=ITMS8.0&locale=EN_US


Other Solutions/products areas seems to be fine:

http://SMPServer.domain.local:8080/unifiedhelp/#/cs?vid=Policies_View&product=ECV&context=ITMS8.0&locale=EN_US

Steps to reproduce:
1) Open Altiris Console
2) Go to Manage>Policies>Monitor and Alerting>Monitor Policies>Windows
Server Health>Windows Server Performance Health Monitor Policy
3) Go to Help > Context

Result:
The following validation error displayed:

Validation Error 

 The "product" value in the URL is missing or invalid. Please contact your system administrator. 

This issue is visible on any Monitor Solution related context documentation for UHS

Validation Error 

 The "product" value in the URL is missing or invalid. Please contact your system administrator. 

Environment

ITMS 8.0 and later

Cause

Known issue. The issue is because of a residual entry in the document source for “Monitor_Servers”. This should be changed to “Mon”

Resolution

A fix is targeted for the offline files for ITMS 8.1 release (as well 8.0 HF4 and later). The online version of these files have been updated and it should be available when yuo choose to see the online version of the documentation:

Attachments