Remote Connect Case Sensitive E-mail Addresses
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Remote Connect Case Sensitive E-mail Addresses

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Article ID: 163585

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Updated On:

Products

Web Security.cloud

Issue/Introduction

Remote Connect Roaming users are required to input their email address in the correct case as the username is case sensitive.

 

Cause

When the Schemus, Synchronization Tool sends the data to the cloud, an MD5 checksum is created which would be different when a different case is used. 

Example: [email protected] is different to [email protected] which is different to [email protected] 

Resolution

Please follow these steps after opening Schemus:

  1. Select the desire configuration profile
  2. Select Users
  3. Click on Modify
  4. Go to LDAP Search
  5. Click Advanced
  6. Under Primary mail change value:  %mail%
  7. To one of the below strings - please note, the uppercase & lowercase ones are different:
     
    • Lowercase
      %mail{s/(.*)/toLowerCase($1)/e}%
       
    • Uppercase
      %mail{s/(.*)/toUpperCase($1)/e}% 
       
    • This will force schemus to re-write the email address to all lowercase or uppdercase.

IMPORTANT NOTE:
To do this via schemus the existing list would need to be removed by uploading a blank text file and then re-adding the users by doing another sync with the updated settings as described above. Just running a replace upload with lower case addresses will not work as the database is not case sensitive and so will ignore any upper/lower case differences. 

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